17-70 os lens

Emy

New Member
I just bought these lens but there is some noise/rattle coming from inside of it while gently shake side to side, it is normal operation of the built in OS? It's a bit annoying but I have to get used with it.
 

tc95

Well-Known Member
Emy...I would not say a rattling is a normal operation of the lens...you might want to send it to Sigma for a tune-up...if you have a receipt...it should not cost you...if you don't the most I ever paid for this service is about 85USD...

I had a 90mm Macro that did that...it was actually a loose element...the tech told me good thing that it did not get worse...it would have caused other issues...

I would at least call Sigma and find out from them...

Good Luck.... Tony C. :z04_cowboy:
 

Emy

New Member
Emy...I would not say a rattling is a normal operation of the lens...you might want to send it to Sigma for a tune-up...if you have a receipt...it should not cost you...if you don't the most I ever paid for this service is about 85USD...

I had a 90mm Macro that did that...it was actually a loose element...the tech told me good thing that it did not get worse...it would have caused other issues...

I would at least call Sigma and find out from them... I will see if works fine when my camera arrives.

Good Luck.... Tony C. :z04_cowboy:
Hi Tony,

I have got an email from Sigma Service UK stating:


"This is completely normal for OS lens, the image stabilasation works off a floating optic and this is only magnetised by the metering on the camera, so when the lens is off the camera the optic will move about, this will not cause any issues to the optic. When the OS is on the mechanism will make a buzzing noise this will be hearable in a dead quiet room for example, this noise will remain until approx. 20 seconds after the camera is turned off. "

Hope this helps.

...So as it says in the email it seems that is normal.
 

tc95

Well-Known Member
Cool...sounds like it is part of there OS lenses...thanks for following up...

Tony C....:z04_cowboy:
 
Top