My SD9 doesn't work well with manual flashes

klazzera

Member
hello, as i pointed i have an sd9, as sigma flashes are too expensive for my budget, i prefer to use manual flashes. as they have only one pin(not counting the side one), i thought first it shouldn't be a problem for camera to fire it. but when i plug the flash on the camera, camera crashes on the 1st-5th shot and needs power reset. please can you share your experiences with using your sigma camera with different flashes? and if you don't have this kind of problems, can you please describe the flash you use?

also where can i find a cheap hot-shoe remote cable? can i just make it with a 2.5mm mono plug?

thanks.
 

fli

New Member
Hi klazzera, you may want to check your flash's trigger voltage, older manual flashes often have trigger voltage in the order of hundreds of volts which could damage the modern DSLRs. Typically, the modern DSLR's hot shoe can only handle 6~10V. To measure the trigger voltage of your flash, use a volt meter and measure the voltage between the center contact and one of the side contacts while firing the flash. If your flash's trigger voltage is in the order of hundreds of volts, you can still use it with your SD9 providing you use oone of the safe sync device between your flash and the SD9's hot shoe. Google Wein Safe Sync.
Regarding to the cable, you still have to deal with the trigger voltage issue.

Hope this helps.

Frank
 

klazzera

Member
thanks for the info, i didn't measure but i'm sure it's because of the high voltage. i remember when i used that flash on my old zenit, i always got a little shock from the pc socket when i shot with flash.

i found some diy safe sync circuits on the net, gonna try one, and probably'll report in the evening.
 

tc95

Well-Known Member
klazzera...Play with your camera a little and make sure you did not damage any of the electronics...My friend burned the internal flash and hotshoe by putting an old SB-10 on his D90...last year..cost him about $300 from Nikon to fix...

Tony C. :z04_cowboy:
 

klazzera

Member
thanks for the tip, before trying the diy sync safe, i had to fix my broken flash with the trigger coil i took out from a broken minolta dynax 5000 camera. but i wasn't able to trigger flash manually with the safe sync circuit and i'm afraid to try it on camera. i'll just continue to use my flash manually without plugging it on the camera for a while until i buy a sigma flash. then i can use the old one as slave.

edit: i tried that sb-10 on my sd9 too, but it just didn't fire. no damage done
 
Top