Pb with OM2 SP

fronin

New Member
Hola a todos from Bilbao,
I got an OM-2S which works well except... the mirror doesn't go all the way up when fired. All the rest seem correct.
Does anyone know of such a problem and if there is an easy way to check what's wrong. I'm afraid servicing it would be more expensive than its actual worth (if there are still places to do it...).
thanks
François
 

weedram

Well-Known Member
Replace the batteries. Do NOT use alkaline batteries. Yous silver-oxide batteries, SR44 type. Nearly spent or alkaline batteries can cause this symptom.
 

omtech1

Well-Known Member
> Parts are very limited for the 2S. It may need a new mirror mechanism.

___________________________________ John Hermanson Camtech Photo Services, Inc. 21 South Lane, Huntington NY 11743 631-424-2121 | Olympus OM Service since 1977
Please, Log in or Register to view URLs content!
| omtech1 AT verizon.net
 

twc50

New Member
[My OM 2sp just froze. The Mirror is up, the Shutter wont fire and the = film advance will not work. Cant advance the shutter ring into manual = and B range. Batteries are fine though and the meter etc works fine = too. Anybody for parts? The body etc are ex.]
 
W

walrichard

> [No need for parts probably. Just do a reset (Check-Reset on the > auto/manual key on top left). It happened to me twice. Richard > Waldron]
 

omtech1

Well-Known Member
> If mirror is all the way up, try new silver oxide batteries first. Make sure all bottom cover screws are tight. To go into mechanical B/60 shutter speeds, you first have to turn ring to "1", then press and hold tiny "B Lock" button next to sync socket as you turn ring the rest of the way. If this is just a conventional lockup from dead batteries, shutter should reset as you turn the ring into mechanical zone. If it doesn't reset or mirror is only partway up, then you have other problems. John CPS,
Please, Log in or Register to view URLs content!
 

fronin

New Member
Thank you John and to you all who answered. Batteries are new, all manual speed works normally etc etc... I'm afraid I got a "hardware" problem with the mirror mechanism. It stops before reaching the top position et about 2/3 of the way and falls back normally after.
Oh well, I will look for dead OM-2SP in ebay and try to save mine although it seems a little complicated... Anyone knows if the mirror mechanisme is common between OM2SP and OM2n or OM2SP and OM4? Once in a while, there are some cadavres for sale...
If I fail, I migth have spare parts for whoever is interested...
Thanks again
François
 
Top