CI Photocommunity

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

Problem with Dimage Scan Elite 5400 II

Larry

New Member
I've recently purchased an Elite 5400 II film scanner and love it's ease of use and quality. However, it has just stopped in the middle of a B&W negative scan; the film carrier is deep inside the scanner body; the Eject button on the scanner does nothing to help; and the Utility app reports an error when booting and then quits.

Anyone have any idea of what to do to get the scanner to eject the carrier?

Thanks!
 

jsmisc

Well-Known Member
How frustrating!
I wonder if uninstalling and reinstalling the software would help. Otherwise, I would contact KonicaMinolta.
John
 

Larry

New Member
Thanks, John, we think alike. I did the uninstall-install of the software and it didn't help. Then called KM this morning and the tech suggested that I ask for a replacement. When I said that the stuck carrier had a negative strip still in it, he said I would need to return it to them in NJ to open it, do any needed repairs and return it to me - a 2-3 week turnaround.

So, I opened the box myself - just 7 screws - easily pushed the carrier out the front of the unit, returned the cover and it is operating very well once again. Nice to know that it is so easy to handle this sort of problem.

Larry
 

jsmisc

Well-Known Member
I'm glad you got it sorted. What a pain. That was very brave! Still, as you say it's good to know that you can just do that to fix it. I will bear it in mind in case it happens to me. Thanks and best wishes,
John
 
Top