CI Photocommunity

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

RTS II aperture readout in viewfinder does not match the lens

T

trisnadi

Just noticed my RTS II, the aperture readout in the viewfinder is one stop difference with lens setting. Ex&le if I set f/2.8 in the lens, the viewfinder shows f/2.0.

I am using CZ 60 f/2.8.

Help!
Trisnadi
 

wilsonlaidlaw

Well-Known Member
Trisnadi, This is a very common fault particularly on MM lenses. You can often cure it as follows run the aperture from one end of the range to the other about twenty times. Remove the lens from the camera and repeat. Clean bayonet mating surfaces of lens and camera making sure there is no fluff in end stops of bayonet tracks. Replace the lens two or three times making sure it clicks well each time. This will often cure this fault, but if it does not, you may well have lubricant on aperture blades or on aperture control mechanism. I am afraid then it is a trip to the Contax shop but generally this is not the usual price Contax repair and will not wholly break the bank. Wilson
 
D

davidfung

Hi all. I have a similar problem with my 85/1.4. It constantly reads a half a stop faster than it is on my ST. So on the camera, it says it is a 1.2 not a 1.4. This lens functions perfectly on my RTSII, and just had a new bayonet installed. It has a tight fit onto the ST and very little play. Can anyone help me out here? This is a second hand lens, but the glass is in great condition, and would love to be able to use it on both the ST and the RTSII. Any help is much appreciated!
 
T

trisnadi

Wilson, thanks for the information. I've tried cleaning the mount and bayonet, but the problem persists. I'll try rotating the aperture ring twenty times as you suggested.

Thanks, Trisnadi
 
R

rtcarter

I have the same problem with my RTSII/50/1.4. It is out by a half stop (so at 2.8 on the aperture ring the viewfinder readout says 2.0). The technique above has not cleared it, unfortunatley

I can live with this for the time being, but right now how should I use the camera - is it likely to be metering correctly, or under or over exposing?

Hope you can help

RC
 
W

wojo

Metering should be fine, if your negs come out OK. That is the main concern, the end product so to speak.
If the indicated shutter speed changes when you change the aperture on the lens, the coupling between the lens and body are functioning OK.
You can adjust the lens to give the correct aperture reding in the viewfinder by loosening the one or two screws securing a little "L" shaped st&ing on the back of the lens. The st&ing is at the top of the lens when mounted on the body. Just a little change one way or the other should get the indication right on. All the st&ing does is give a referance point for the maximum aperture opening to the body.
If that doesn't do it see the threads regarding aperture and lens mount ring. Bent mount rings are sorta common.
J W
 
N

nomed

I have had the same problem with a couple of lenses and the problem seems to also vary between bodies. For ex&le, my 50mm lens reads correctly on my 167MT, but is off by half a stop on my RTSII. Another lens gave wonky reading on both bodies. My gut feeling is that this does not affect my negatives. I have not tried this lens with slides to see if the metering is affected.
 

vhaogan

New Member
I had the same problem with the 50/1.4. I brought the lens in for a cleaning estimate, the service center fixed the problem free of charge. I was told it's a minor problem.
Hope this help.
 
N

nomed

Hi everyone,

I have tried loosening the screws on my lenses to make the adjustment but the screws are so tight I'm afraid I'll damage the lens trying to get them out. Does anyone know a way to loosen them in a safe manner? Thanks. Rob
 
Top