CI Photocommunity

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

SD14 Firmware 1.08 released!

Guest .

Banned
Hi all,

SIGMA just released new firmware for their SD14.

Please, Log in or Register to view URLs content!


The new firmware is said to end the problem with mega file sizes when shooting raw, make the cam more stable (mine never made such trouble..) and write exact shutter speeds to the exifs when using the bulb mode.

Installation did not cause any pronblems so far.

See you with nice pictures

Klaus

EDIT: Please do follow the internet instructions to the word, avoiding any potential problems during the update process!
 

foveonfan

Well-Known Member
It looks like we have something in common, Klaus, as I too have not experienced any problems with either my SD10 nor SD14 bodies. They continue to serve me very well.

What I do want to suggest to members here is that it is important to read the instructions on the Firmware UpGrade site carefully and follow them to the letter, thereby avoiding any potential problems.
 

Guest .

Banned
Hi Jim,

nice to read from you! :)

Thanks for your recommendation ... you are absolutely right. We had reports from German users who crashed their cams with 1.06 firmware.
If you are very unlucky, you will have to send your SD14 to the SIGMA-service for reactivation. SIGMA Germany did that free ... I do not know, what SIGMA does in other countries??
Anyway ... I did some "EDIT" above!:)

See you with nice pictures

Klaus
 

foveonfan

Well-Known Member
Thank you for the edit, Klaus. I sincerely hope that WE save users some inconvenience.

I like your saying, "See you with nice pictures".
 

Guest .

Banned
Hi All,

as it seems, 1.08 works!

Those few users, who report problems with their SD14 being instable, also report that their problems occurred during earlier firmware versions as well.

See you with nice pictures

Klaus
 

pawel

Member
Hi,

I have a question for everyone with the 1.08 firmware installed. my SD14 had the 1.08 when I check the firmware version in the menu, and I've overwritten it with 1.08 personally to make sure of this.

Regardless, the ISO50 option added in 1.05 is not there ( the camera can select ISO100 through ISO800 ) and I get freezes whenever shooting multiple images in autobracket. Something that should have been solved in the later firmware versions.

It's almost as if the firmware version reads 1.08, but in reality it is another version instead. Anyone with a similar experience and solution?

Thanks in advance
 

Arvo

Well-Known Member
You need to activate extended mode to use ISO50 and ISO1600.

To activate ext mode:
- Press Func 7 times and hold.
- Turn Command Dial so it reads Ext at the top LCD.

What about lockups, then try another brand of CF card - made huge difference for some users.
 

pawel

Member
Thanks a lot Arvo :) The ISO50 and ISO1600 options are now available. As for the CF card, perhaps that is something to look into before the summer holiday. Can you recomend a type or brand of card? Right now I'm using a Sandisk ultra2 4gb. That one can be found in most stores in my area, so it seemed like a safe choice.

Alternatively I can go by a photography store and ask to try some of the cards out. Hopefully the store people won't object. For now though, I'm just staying away from autobracketing.
 

Arvo

Well-Known Member
Can't recommend CF card - I've got Sandisk 4GB too, but I'm using firmware 1.05 (from reading varous forums that seemed most stable and it was already on my SD14 when I got it) and I don't use autobracketing either.

Reading other forums Sandisk is usually preferred, but some people have experienced lockups with them too - and after starting use (older) Transcend problems went away.

You may try some older cards then - SD14 doesn't use all these ultra-super-extreme speeds anyway; maybe older (a bit slower) cards are more compatible.
 

tc95

Well-Known Member
Hello....I will put my two cents in...

Turn off the image review feature on your SD14...also..the SD14 does not use the faster speeds of the cards...as Arvo stated...but I found the buffers in the faster cards...seems to let you shoot several more images than with the slower cards....I use PNY 266x Optima Pro cards...now even with these cards and the image review off I can take only 5 to 7 images before the camera starts to stick...or take a long time to write....

Good luck...and I hope this helped a little...

Tony C. :z04_cowboy:
 
Top