CI Photocommunity

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

Triggering my studio strobe unit

pinlander

Member
Hi everione, I have this interesting situation thats driving me nuts. I bought a Flashpoint II 620 Monolight strobe unit and here is the problem. The unit has a sync cord plug and also a photocell so it can be set off by another flash. Well no matter what I tried I can't fire the unit with my D100 using the sync cord, for which I had to buy an adapter that fits into the shoe on top of the camera. I believe its called an AS-15 since Nikon failed to put a plug right on the camera. I tried all kinds of setting on the camera, bought a new sync cord etc but nothing works. Here is the interesting part, however I can fire the strobe using a second strobe to set it off through the photocell and my D100 will fire that using the same sync cords. To eliminate that it might be a strobe/cord problem I tried using one of my old Nikon F2 cameras and it fires the Monolight. So I'm at a total loss. I would like to be able to fire the unit without having a second strobe set it off. Could it possibly be the current it takes to fire the unit and the D100 not working with it? Any suggestions? I called Adorama where I bought it and they are of no help. So if anyone has an answer I would appreciate it.
 
A

anton_beroflex

Hello Lou,
find a Voltmeter (a cheap one, too) and go measuring both Strobes's triggering Voltage. Maybe the AS-15 is designed to ignore high Voltages, in respect of the Camera hot-shoe; also You might do measures over the AS-15.
Or maybe there is a diod, inside the AS-15; and the Monolight gives inverted (+) and (-) tips. Standard should be (+) in the centre.
Which kind of plug is there on the Flashpoint II 620 Monolight 's body? photo-PC, phono-Jack, ... ?
Anton
 

pinlander

Member
Thanks for the reply Anton, the voltage is the only thing I figgure it might be. Great idea about the voltage meter and I have one so I will try it. The monolight has a female phone jack the larger one not the mini jack. I guess I can rig up a plug so I have 2 exposed wires to attach the voltmeter to, since the other end taht plugs into the AS-15 is a regular PC plug and that makes it sort of tricky to test with the voltmeter.The other flash unit that the D100 works with has a PC plug. I'll try reversing the polarity too and see what happens....thanks again
happy.gif


Lou
 
Top